Skip to main content
← All vulnerabilities
CVE-2026-32248GHSA-5FW2-8JCV-XH87BIT-PARSE-2026-32248

Parse Server: Account takeover via operator injection in authentication data identifier

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.6.0-alpha.12, 8.6.38
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.12 and 8.6.38, an unauthenticated attacker can take over any user account that was created with an authentication provider that does not validate the format of the user identifier (e.g. anonymous authentication). By sending a crafted login request, the attacker can cause the server to perform a pattern-matching query instead of an exact-match lookup, allowing the attacker to match an existing user and obtain a valid session token for that user's account. Both MongoDB and PostgreSQL database backends are affected. Any Parse Server deployment that allows anonymous authentication (enabled by default) is vulnerable. This vulnerability is fixed in 9.6.0-alpha.12 and 8.6.38.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • parse-community parse-server

    From 9.0.0 · fixed in 9.6.0-alpha.12; fixed in 8.6.38

  • parse-servernpm

    From 9.0.0 · fixed in 9.6.0-alpha.12

  • parse-servernpm

    fixed in 8.6.38

References 3

GitHub · parse-community/parse-server