Skip to main content
← All vulnerabilities
CVE-2026-3220

Multiple Plugins - Unauthenticated Stored XSS via Minify Library

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.15, 2.4.2, 7.7.9
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

The Autoptimize WordPress plugin before 3.1.15, Clearfy Cache WordPress plugin before 2.4.2, Speed Optimizer WordPress plugin before 7.7.9 are vulnerable to unauthenticated Stored Cross-Site Scripting (XSS) due to a predictable replacement hash used during the HTML minification process and abusing a regular expression. This allows an attacker to inject arbitrary HTML attributes in the final HTML output by anticipating the placeholder format.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Unknown Autoptimize

    fixed in 3.1.15

  • Unknown Clearfy Cache

    fixed in 2.4.2

  • Unknown Speed Optimizer

    fixed in 7.7.9

References 1

wpscan.com