Skip to main content
← All vulnerabilities
CVE-2026-31908

Apache APISIX: forward auth plugin allows header injection

Published
Last modified
published
Not listed in CISA KEV
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache APISIX

    From 2.12.0 · through 3.15.0

References 2

lists.apache.org

GitHub · MehranTurk/CVE-2026-31908