Skip to main content
← All vulnerabilities
CVE-2026-30962GHSA-72HP-QFF8-4PVVBIT-PARSE-2026-30962

Parse Server has a protected fields bypass via logical query operators

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.6.19, 9.5.2-alpha.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • parse-community parse-server

    fixed in 8.6.19

  • parse-servernpm

    From 9.0.0 · fixed in 9.5.2-alpha.6

  • parse-servernpm

    fixed in 8.6.19

References 3

GitHub · parse-community/parse-server