Skip to main content
← All vulnerabilities
CVE-2026-29146GHSA-H468-7PVH-8VR8BIT-TOMCAT-2026-29146

Apache Tomcat: EncryptInterceptor vulnerable to padding oracle attack by default

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.0.116, 10.1.53, 11.0.20
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 11.0.0-M1 · through 11.0.18; From 10.0.0-M1 · through 10.1.52; From 9.0.13 · through 9.0.115; From 8.5.38 · through 8.5.100; From 7.0.100 · through 7.0.109

  • org.apache.tomcat:tomcat-tribesMaven

    From 9.0.13 · fixed in 9.0.116

  • org.apache.tomcat:tomcat-tribesMaven

    From 10.1.50 · fixed in 10.1.53

  • org.apache.tomcat:tomcat-tribesMaven

    From 11.0.0-M1 · fixed in 11.0.20

  • org.apache.tomcat:tomcatMaven

    From 9.0.13 · fixed in 9.0.116

  • org.apache.tomcat:tomcatMaven

    From 10.1.50 · fixed in 10.1.53

  • org.apache.tomcat:tomcatMaven

    From 11.0.0-M1 · fixed in 11.0.20

  • org.apache.tomcat:tomcat-tribesMaven

    From 8.5.38 · through 8.5.100

  • org.apache.tomcat:tomcatMaven

    From 8.5.38 · through 8.5.100

  • org.apache.tomcat:tomcat-tribesMaven

    From 7.0.100 · through 7.0.109

  • org.apache.tomcat:tomcatMaven

    From 7.0.100 · through 7.0.109

References 1

lists.apache.org