Skip to main content
← All vulnerabilities
CVE-2026-29072

Discourse missing permission check for policy creation in discourse-policy

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2026.1.2, 2026.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, users who do not belong to the allowed policy creation groups can create functional policy acceptance widgets in posts under the right conditions. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, disable the discourse-policy plugin by disabling the `policy_enabled` site setting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • discourse discourse

    From 2026.1.0-latest · fixed in 2026.1.2; From 2026.2.0-latest · fixed in 2026.2.1

References 1

GitHub · discourse/discourse