GitHub OAuth Scope Validation
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 11.6.1, 11.5.4, 11.4.5, 10.11.15, 1.0.1-0.20260318132218-6e6b740c4852, and 4 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate the OAuth token scope on the callback which allows an authenticated Mattermost user to gain access to private repositories via modifying the scope parameter in the GitHub authorization URL.. Mattermost Advisory ID: MMSA-2026-00628
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- Mattermost Mattermost
From 11.6.0 · through 11.6.0; From 11.5.0 · through 11.5.3; From 11.4.0 · through 11.4.4; From 10.11.0 · through 10.11.14
- github.com/mattermost/mattermost-serverGo
From 11.6.0 · fixed in 11.6.1
- github.com/mattermost/mattermost-serverGo
From 11.5.0 · fixed in 11.5.4
- github.com/mattermost/mattermost-serverGo
From 11.4.0 · fixed in 11.4.5
- github.com/mattermost/mattermost-serverGo
From 10.11.0 · fixed in 10.11.15
- github.com/mattermost/mattermost-plugin-githubGo
fixed in 1.0.1-0.20260318132218-6e6b740c4852
- github.com/mattermost/mattermost-serverGo
From 10.11.0+incompatible · fixed in 10.11.15+incompatible; From 11.4.0+incompatible · fixed in 11.4.5+incompatible; From 11.5.0+incompatible · fixed in 11.5.4+incompatible; From 11.6.0+incompatible · fixed in 11.6.1+incompatible