Skip to main content
← All vulnerabilities
CVE-2026-28282

Discourse vulnerable to group membership addition permission bypass via discourse-policy plugin

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2026.1.2, 2026.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Discourse is an open-source discussion platform. Versions prior to 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 have a security flaw in the discourse-policy plugin which allowed a user with policy creation permission to gain membership access to any private/restricted groups. Once membership to a private/restricted group has been obtained, the user will be able to read private topics that only the group has access to. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. As a workaround, review all policies for the use of `add-users-to-group` and temporarily remove the attribute from the policy. Alternatively, disable the discourse-policy plugin by disabling the `policy_enabled` site setting.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • discourse discourse

    From 2026.1.0-latest · fixed in 2026.1.2; From 2026.2.0-latest · fixed in 2026.2.1

References 4

GitHub · discourse/discourse