Skip to main content
← All vulnerabilities
CVE-2026-28223GHSA-P4V8-RW59-93CQPYSEC-2026-2308

Wagtail: Improper escaping of HTML (Cross-site Scripting) in simple_translation admin interface

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.3.8, 7.0.6, 7.2.3, 7.3.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Wagtail is an open source content management system built on Django. Prior to versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1, a stored cross-site scripting (XSS) vulnerability exists on confirmation messages within the wagtail.contrib.simple_translation module. A user with access to the Wagtail admin area may create a page with a specially-crafted title which, when another user performs the "Translate" action, causes arbitrary JavaScript code to run. This could lead to performing actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been patched in versions 6.3.8, 7.0.6, 7.2.3, and 7.3.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • wagtail wagtail

    fixed in 6.3.8; From 6.4rc1 · fixed in 7.0.6; From 7.1rc1 · fixed in 7.2.3; From 7.3rc1 · fixed in 7.3.1

  • wagtailPyPI

    fixed in 6.3.8

  • wagtailPyPI

    From 6.4rc1 · fixed in 7.0.6

  • wagtailPyPI

    From 7.1rc1 · fixed in 7.2.3

  • wagtailPyPI

    From 7.3rc1 · fixed in 7.3.1

  • wagtailPyPI

    fixed in 6.3.8; From 6.4 · fixed in 7.0.6; From 7.1 · fixed in 7.2.3

References 9

GitHub · wagtail/wagtail