Skip to main content
← All vulnerabilities
CVE-2026-27491

Discourse has a bypass of official warnings messages by non-staff users

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2026.1.2, 2026.2.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Discourse is an open-source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2, a type coercion issue in a post actions API endpoint allowed non-staff users to issue warnings to other users. Warnings are a staff-only moderation feature. The vulnerability required the attacker to be a logged-in user and to send a specifically crafted request. No data exposure or privilege escalation beyond the ability to create unauthorized user warnings was possible. Versions 2026.3.0-latest.1, 2026.2.1, and 2026.1.2 contain a patch. No known workarounds are available.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • discourse discourse

    From 2026.1.0-latest · fixed in 2026.1.2; From 2026.2.0-latest · fixed in 2026.2.1

References 4

GitHub · discourse/discourse