Skip to main content
← All vulnerabilities
CVE-2026-27166

Discourse vulnerable to HTML injection via prohibited iframe URLs

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2026.3.0-latest.1, 2026.2.1, 2026.1.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Discourse is an open source discussion platform. Prior to versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2, insufficient cleanup in the default Codepen allowed iframes value allows an attacker to trick a user into changing the URL of the main page. This issue has been fixed in versions 2026.3.0-latest.1, 2026.2.1 and 2026.1.2. To workaround this issue, remove Codepen from the list of allowed iframes.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • discourse discourse

    fixed in 2026.3.0-latest.1; From 2026.2.0-latest · fixed in 2026.2.1; From 2026.1.0-latest · fixed in 2026.1.2

References 2

GitHub · discourse/discourse